Перейти к публикации
MRC

Не понимаю, как запустить лаунчер на Linux Mint 19.

Рекомендованные сообщения

MRC

Да, конечно я тот еще извращенец, но мне нужна помощь, постоянные ошибки при запуске, кучу тем на форумах посмотрел, ничего не помогает. (Java 8 OpenJDK установлена, может другой пакет нужен, не знаю)
При запуске выдает ошибку(скрин ниже) и создает файл краш-репорта.

RedServer V3 Crash Report
========================================
Launcher version: 3.4.4 (Build #1471)
Launcher branch: master
Launcher location: /home/mrc/Загрузки/RS3.jar
java.vendor=Oracle Corporation
java.version=11.0.3
java.home=/usr/lib/jvm/java-11-openjdk-amd64
user.home=/home/mrc

java.lang.NoClassDefFoundError: javafx/application/Application
    at java.base/java.lang.ClassLoader.defineClass1(Native Method)
    at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1016)
    at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)
    at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:802)
    at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:700)
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:623)
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    at redserver3.cM.main(cM.java:86)
Caused by: java.lang.ClassNotFoundException: javafx.application.Application
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    ... 10 more
image.thumb.png.39b54ac7b0400b219b16372d8e13da72.png

 

 

Изменено пользователем MRC

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
BlackSun

11я жаба не покатит, даже с OpenJDK. Ставь 7 8ю оракловскую.

Изменено пользователем BlackSun

nodes.gif.707c73bf76fe5592b4e154b63d92771b.gif

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
MRC
19 минут назад, BlackSun сказал:

11я жаба не покатит, даже с OpenJDK. Ставь 7ю оракловскую.

Я конечно понял, что не пойдет...У меня так же установлен пакет 8 джавы.. Обязательно 7?
Просто на сайте написано:

Для запуска игры Вам необходимо иметь установленную Oracle Java 8 на компьютере. Самую последнюю версию можно загрузить с официального сайта
На другой версии Java (например 12) лаунчер и игра работать не будут!

просто так же из этого появляется еще одна проблема, невозможность установить 7-ую;image.thumb.png.bf7707d69d9fc891597ed6372e6368d8.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
BlackSun

@MRC упс, да, 8. По старой памяти 7ю приляпал..

В догонку:
 

Цитата

 

update-java-alternatives --list

sudo update-java-alternatives --set /path/to/java/version

 

Чтобы выбрать нужную версию явы.

Запуск лаунчера без его самостоятельного перезапуска:

Цитата

java -jar /path/to/launcher.jar --run

 

Изменено пользователем BlackSun

nodes.gif.707c73bf76fe5592b4e154b63d92771b.gif

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Andrey

OpenJDK 8 нужен с установленным пакетом openjfx

Oracle Java теперь только руками ставить. Все ссылки на скачивание Oracle закрыли. Скоро начнут требовать мешок денег...


Зачем мне подпись?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
exend
1 час назад, TheAndrey сказал:

openjfx

После его установки ничего меняется, и появляется такая же ошибка как на скрине.


image.png.71f7c39369e5c1f3688fd965639ee865.png

30.10.2014 в 17:07, vadim189 сказал:

виндовс переучтанавливаеш а толку нет всеравно

24.06.2014 в 14:43, SergeJ15 сказал:

Андрей помнишь ты ставил перд модерацию сообщений eXend'a - в общем теперь я понял почему. Может вернуть ее, не думаю что нам нужен местный "троль"?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Endless
20 часов назад, eXend сказал:

После его установки ничего меняется, и появляется такая же ошибка как на скрине.

Если Java 8 ставить не из PPA, а руками - работает. Потом сверху уже из PPA накатить openjfx и всё.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×
×
  • Создать...